AI and Forbidden area troubles

Leave me alone ... I got this
Post Reply
User avatar
intrepidbiped
Posts: 5
Joined: 21 Apr 2019 06:12

AI and Forbidden area troubles

Post by intrepidbiped » 21 Apr 2019 09:47

Reclusiarch


AI problems, big surprise.
__________________________________________________________________

Alright guys here is my problem, well, problems. First of all the AI
are completely ignoring ForbiddenAreas in the editor and in-game. Aside
from that my level plays just fine in the editor. However, as soon as I
play it with outside the editor some of the AI completely disappear.
Others randomly die throughout the level and even more become
completely unresponsive. Also many GeomEntites become intangible. I
walk right through them as if they weren't there. I did increase the
size of them but it works fine in the editor.
Why why why? And before anyone asks; I did generate AI navigation, I
did export to engine, and I did generate surface texture. So any ideas
on why the editor hates me?
*EDIT* Also I'm having the same problem as one of the blokes in this
thread was Time of Day is killing me (not anymore) Which would be
the TOD resets to sometime at night, only in-game though. In the Editor
it is fine. But I've tried all of the fixes they had but to no avail.


93confirmed
__________________________________________________________________

I'm having A LOT of problems with AI, editor freezes, and the editor
completely crashing. It could be my PC as I'm running on a high-end
single core, 8800GT, and 2GB RAM or it might be the editor itself.





There seems to be a lot of confusion regarding how you can use
ForbiddenAreas.
They are meant to define where AI should NOT go, but many people are trying to use them to keep AI in a specific area which is really the opposite of how they work.
If you place AI inside of a ForbiddenArea they will ignore it until
they get outside of the area because they 'know' they are not supposed to be within that
boundry.
Once they get outside of the ForbiddenArea they will not be able to
navigate back into it which is exactly how it is supposed to work. If you want to
allow AI to move within a ForbiddenArea, you must use an AINavigationModifier to 'show'
the AI where they may go within the ForbiddenArea and this requires proper setup of
AIPoints as Entry/Exit points.
Now I should probably state here that this applies to AI ->
ForbiddenArea. Part of the confusion is arising from the fact that there is an Entity
with the same name... but a different purpose.
It resides in Entity -> Multiplayer -> ForbiddenArea and is used to
define the borders of multiplayer levels...
Hope this maybe helps someone out there with their ForbiddenArea
issues.



McGinge
Trainee

__________________________________________________________________

1) Make sure that AutoDisable and HiddenInGame is checked off in your
RollUpBar for your AI.
2) May sound silly, but I'm just covering all bases, make sure that ALL
your AI are archetype entities, and not brushes or geom entities.
3) Generate triangulation, as well as the all navigation.
4) The ones that die are probably cause they fall into the water etc.
put forbidden areas and/or some trees/rocks/entities/terrain etc. to
realistically block them. Also, some die if you place them too close to
things like vehicles that you havent placed properly that just fall on
them and die.
5) For your GeomEntity trouble, try reloading the script in the
rollupbar, or using brushes if its not required that the GeomEntities
move.
6) Keep exporting to engine and saving at regular points, and also
restart the editor if things get really bad.
Hope SOME of that helps!



Reclusiarch


Thread Starter Thread Started by Reclusiarch
__________________________________________________________________

Thanks, intrepidbiped that cleared up some confusion about the
Forbiddenareas. But I have a question: How do you make an AI stand in
one place but still shoot and whatnot. And, no it's not the the RAM
-for me at least. It's usually running at 600 to 800 and I've got 3
gigs. Some of the same problems still remain unfortunately. Namely the
GeomEntities and the vanishing AI... Ah well, I guess I'll just have to
keep fiddling with it. Oh, and the map has no Water so that isn't
killing the AI, they just randomly die..


McGinge
Trainee
__________________________________________________________________

To get him to stand in one place, there may be a node in AI in the
flowgraph section, Im not at my gaming PC atm so cant look...
Or you could just draw a big forbidden boundary/area round where you
want him to stay...


Sorry, forgot to put that in my description, McGinge... you are correct
about the
ForbiddenBoundary.
That seems to be the best way to keep AI restricted to a certain area.



Reclusiarch


Thread Starter Thread Started by Reclusiarch
__________________________________________________________________

Blargh! Some of the AI still vanish some still disappear and some
become unresponsive. Also, some of them are going way farther than they
should. What I mean by that is I lowered the comm range, sight range
and attack range so they have to stay closer yet they seem to be
hearing things very very far away. GeomEntities are still intangible
and my TOD changes to sometime at night and I lose my fog. Everything,
absolutely everything is working just fine in the editor but as soon as
go in-game it decides to not work. One last bit of info, I renamed the
level at one time, could that be the problem? I wouldn't think so but I
know it can cause problems...

Post Reply